No ''Job well done" in v5 for x64?

delphi package - automated exception handling

No ''Job well done" in v5 for x64?

Postby FredS » Mon Feb 04, 2019 11:08 pm

Performed a couple of tests on freshly installed v5 and I don't see the ''Job well done" dialog.
Still shows in Win32, issue or new normal?
FredS
 
Posts: 97
Joined: Mon May 11, 2015 9:42 pm

Re: No ''Job well done" in v5 for x64?

Postby madshi » Mon Feb 04, 2019 11:16 pm

Please try the latest beta, that should probably fix this:

http://madshi.net/madCollectionBeta.exe
madshi
Site Admin
 
Posts: 10249
Joined: Sun Mar 21, 2004 5:25 pm

Re: No ''Job well done" in v5 for x64?

Postby FredS » Tue Feb 05, 2019 12:10 am

That does the trick, felt like my job was NOT 'well done' :D
FredS
 
Posts: 97
Joined: Mon May 11, 2015 9:42 pm

Re: No ''Job well done" in v5 for x64?

Postby madshi » Tue Feb 05, 2019 7:52 am

Haha... :D
madshi
Site Admin
 
Posts: 10249
Joined: Sun Mar 21, 2004 5:25 pm

Re: No ''Job well done" in v5 for x64?

Postby FredS » Thu Feb 07, 2019 8:45 pm

madshi wrote:Haha... :D


This beta is very slow under Win64.

I like to have 'Leak checking' turned on for my DUniX testing and under Win32 the 'Well done' dialog pops up quickly while in Win64 it pauses dramatically. Is this possibly a BETA issue?
FredS
 
Posts: 97
Joined: Mon May 11, 2015 9:42 pm

Re: No ''Job well done" in v5 for x64?

Postby madshi » Thu Feb 07, 2019 8:54 pm

Can you explain in more detail when it's slow exactly? During running? At the end, when leaks are reported? Does it matter if there are leaks found or not? Etc...
madshi
Site Admin
 
Posts: 10249
Joined: Sun Mar 21, 2004 5:25 pm

Re: No ''Job well done" in v5 for x64?

Postby FredS » Thu Feb 07, 2019 9:25 pm

madshi wrote:Can you explain in more detail when it's slow exactly? During running? At the end, when leaks are reported? Does it matter if there are leaks found or not? Etc...


After the DUniX test completes, the time it takes for the 'Well done' Dialog to come up can be very long. I also see a quick blimp of the dialog then it disappears until it finally shows much later than in Win32.

That said my last execution was just a final check so I ran without debugger and the Dialog came up immediately.
FredS
 
Posts: 97
Joined: Mon May 11, 2015 9:42 pm

Re: No ''Job well done" in v5 for x64?

Postby madshi » Thu Feb 07, 2019 9:38 pm

So the slowness also happens if there are no leaks at all, correct? And it only occurs inside of the debugger? If so, I don't have any idea how to fix this. After all, if the debugger slows things down, then it's kind of out of my control, no?
madshi
Site Admin
 
Posts: 10249
Joined: Sun Mar 21, 2004 5:25 pm

Re: No ''Job well done" in v5 for x64?

Postby FredS » Thu Feb 07, 2019 10:13 pm

madshi wrote:So the slowness also happens if there are no leaks at all, correct? And it only occurs inside of the debugger? If so, I don't have any idea how to fix this.


With the debugger this only occurs when there are no leaks, which I verified by generating some leaks just now.

madshi wrote:After all, if the debugger slows things down, then it's kind of out of my control, no?


Yup, plus now that I first generated a leak and returned to no leaks it has improved..
FredS
 
Posts: 97
Joined: Mon May 11, 2015 9:42 pm

Re: No ''Job well done" in v5 for x64?

Postby madshi » Thu Feb 07, 2019 11:36 pm

That's extremely weird. And does not seem to happen for me...
madshi
Site Admin
 
Posts: 10249
Joined: Sun Mar 21, 2004 5:25 pm

Re: No ''Job well done" in v5 for x64?

Postby casiosmu » Tue Mar 24, 2020 8:51 am

Thanks for the posted Beta version, it works well. Will there be a release soon? Because I purchased madExcept for our company and now found out, that the beta ignores the licence file.

Regarding the slow collecting:
At my system the collecting time is both the same in the debugger and with directly started program: <1sec after closing the program the collecting window pops up and takes 3-4sec for the collection.
My IDE is Delphi 10.2 Update 3 under Win10 x64 1909, and we develop a x64 program (~50MB unoptimized debug compile).
casiosmu
 
Posts: 2
Joined: Wed Oct 09, 2019 7:10 am

Re: No ''Job well done" in v5 for x64?

Postby madshi » Tue Mar 24, 2020 9:08 am

The beta should not ignore the license file. Does the installer say anything?

3-4sec sounds pretty good to me, but it will depend on how many leaks there are. The more leaks you have, the longer it will take.
madshi
Site Admin
 
Posts: 10249
Joined: Sun Mar 21, 2004 5:25 pm


Return to madExcept

Who is online

Users browsing this forum: No registered users and 7 guests