Shouldn't MailTo be Plain Text?

delphi package - automated exception handling

Shouldn't MailTo be Plain Text?

Postby FredS » Thu Jun 08, 2017 7:46 pm

Doing some work on Bug submission and ran it through my tests when I see that MailTo opens up without the BugReport as its Body and a line telling me about an attachment that doesn't exist..
FredS
 
Posts: 97
Joined: Mon May 11, 2015 9:42 pm

Re: Shouldn't MailTo be Plain Text?

Postby madshi » Wed Jun 14, 2017 9:16 am

Looking through my code, it seems that when there's any attachment, and madExcept has to fall back to simple MailTo emailing, madExcept replaces the normal email body with the bug report. Are you saying that this doesn't work for you?
madshi
Site Admin
 
Posts: 10200
Joined: Sun Mar 21, 2004 5:25 pm

Re: Shouldn't MailTo be Plain Text?

Postby FredS » Wed Jun 14, 2017 5:15 pm

madshi wrote:Looking through my code, it seems that when there's any attachment, and madExcept has to fall back to simple MailTo emailing, madExcept replaces the normal email body with the bug report. Are you saying that this doesn't work for you?


Well, it kind of does if you have other mail options being tried first.
If however I ONLY select MAILTO then it doesn't, I was able to duplicate this in a new project so I am hoping you can as well.

Essentially the main posting is done inside an ExceptActionHandler so most of the time it never reaches MAILTO. But during testing since no other Mail options where checked I got the file attached msg showing.
FredS
 
Posts: 97
Joined: Mon May 11, 2015 9:42 pm

Re: Shouldn't MailTo be Plain Text?

Postby madshi » Thu Jun 15, 2017 7:04 am

Ok, but if you already know for sure that MailTo is going to be used because you didn't activate any other method, why don't you simply adjust the mail subject and body to suit your needs? You can do that here:

http://help.madshi.net/madExceptSettings10.htm
madshi
Site Admin
 
Posts: 10200
Joined: Sun Mar 21, 2004 5:25 pm

Re: Shouldn't MailTo be Plain Text?

Postby FredS » Thu Jun 15, 2017 4:02 pm

madshi wrote:Ok, but if you already know for sure that MailTo is going to be used because you didn't activate any other method, why don't you simply adjust the mail subject and body to suit your needs? You can do that here:
http://help.madshi.net/madExceptSettings10.htm


I've done that in code, but one doesn't find out the reason this happens until it happens.
So all works and is tested, then you uncheck MAPI because of occasional issues with it and Elevated Apps.
Send out your app and bingo, a fix for v5 would seem appropriate.
FredS
 
Posts: 97
Joined: Mon May 11, 2015 9:42 pm

Re: Shouldn't MailTo be Plain Text?

Postby FredS » Tue Dec 31, 2019 10:20 pm

madshi wrote:Looking through my code, it seems that when there's any attachment, and madExcept has to fall back to simple MailTo emailing, madExcept replaces the normal email body with the bug report. Are you saying that this doesn't work for you?


I need to revisit this, we want to be able to force the use of MailTo in instances where clients want to inspect what info is being sent.

I've thought about showing them the Bug Report before attempting to send but that could lock everything for the duration. Which is complicated because we use certain Error dialogs with a 'Tell Us' button which doesn't show the 'Full Exception Dialog'.

Any attempt to turn off all sending but MailTo within the application (in v5) brings up mail with the original issue:
please find the bug report attached


Code: Select all
  exceptIntf.AttachBugReport := False;
  exceptIntf.AttachBugReportFile := False;
  exceptIntf.MailAsSmtpClient := False;
  ...
FredS
 
Posts: 97
Joined: Mon May 11, 2015 9:42 pm

Re: Shouldn't MailTo be Plain Text?

Postby madshi » Fri Jan 03, 2020 8:43 am

Ok, I'll add a fix to the next build. Might take a bit until I get to that, though.
madshi
Site Admin
 
Posts: 10200
Joined: Sun Mar 21, 2004 5:25 pm

Re: Shouldn't MailTo be Plain Text?

Postby FredS » Fri Jan 03, 2020 7:20 pm

madshi wrote:Ok, I'll add a fix to the next build. Might take a bit until I get to that, though.


Leaving SMTP and changing the server to EmptyStr seems to be a workaround.

But when you get there please test MailTo, even when I set (IDE) NOT to attach the bug report it still comes up with the 'bug report attached' message if it is the only option active.
FredS
 
Posts: 97
Joined: Mon May 11, 2015 9:42 pm


Return to madExcept

Who is online

Users browsing this forum: No registered users and 8 guests