Page 1 of 1

problems with 4.0.1, 4.0.2 and Windows 10 x86

PostPosted: Thu Apr 20, 2017 9:18 pm
by Bevan Collins
Hi Madshi,

we have experienced problems with permanent dll injection with the latest releases on Windows 10 x86. Even if the injected dll does nothing, after reboot a CRITICAL_PROCESS_DIED BSOD would occur.
I am using the following API to register the injection:
InjectLibrary(INJECTION_DRIVER_NAME, INJECTION_DLL, ALL_SESSIONS, TRUE, TRUE, NULL);

Reverting back to madCodeHook 4.0 fixed this problem.

Re: problems with 4.0.1, 4.0.2 and Windows 10 x86

PostPosted: Thu Apr 20, 2017 9:29 pm
by madshi
Can you try this beta?

http://madshi.net/madCollectionBeta.exe (installer 2.8.2.2)

Re: problems with 4.0.1, 4.0.2 and Windows 10 x86

PostPosted: Thu Apr 20, 2017 10:57 pm
by Bevan Collins
same problem with beta

Re: problems with 4.0.1, 4.0.2 and Windows 10 x86

PostPosted: Thu Apr 20, 2017 11:06 pm
by Bevan Collins
when investigating the problem I was slowing figuring out the process names that were causing the problem before I reverted to 4.0. If the exclude mask was "dwm.exe|fontdrvhost.exe|log*.exe|lsass.exe|s*.exe|w*.exe", Windows started normally. Hope this helps.

Re: problems with 4.0.1, 4.0.2 and Windows 10 x86

PostPosted: Fri Apr 21, 2017 7:21 am
by madshi
I'm aware of problems with fontdrvhost.exe, but these should be fixed in the latest beta. Did you also update the drivers, when testing the latest beta?

Re: problems with 4.0.1, 4.0.2 and Windows 10 x86

PostPosted: Fri Apr 21, 2017 7:25 am
by Bevan Collins
When I tested the beta, I updated everything but I didn't use an exclude mask when injecting.

Re: problems with 4.0.1, 4.0.2 and Windows 10 x86

PostPosted: Fri Apr 21, 2017 9:35 am
by madshi
Argh, that's bad to hear... :(

Re: problems with 4.0.1, 4.0.2 and Windows 10 x86

PostPosted: Thu Jul 13, 2017 12:03 pm
by madshi
How about this build, does it fix the problem without needing the exclusions?

http://madshi.net/madCollectionBeta.exe (installer 2.8.2.13)

Re: problems with 4.0.1, 4.0.2 and Windows 10 x86

PostPosted: Mon Jul 17, 2017 4:24 am
by Bevan Collins
no, still the same problem with madCollectionBeta.exe (2.8.3.0)

Re: problems with 4.0.1, 4.0.2 and Windows 10 x86

PostPosted: Mon Jul 17, 2017 7:01 am
by madshi
That is surprising, and disappointing. You did update the driver, too?