Could we use the old version of CInjectLib64Func?

c++ / delphi package - dll injection and api hooking
Post Reply
lovenamu
Posts: 23
Joined: Thu Dec 02, 2010 8:21 am

Could we use the old version of CInjectLib64Func?

Post by lovenamu »

Hello

The hooking conflict problem has happened in our customer sites.
After the other security software hooking some processes - for example, java.exe - , we can't hooking that.
Although there is no error, our hooking dll can't be loaded to the process which is already injected by the other security software.
The other securiy software company has told that the uninject problme is not its fault.
After so many tries, we have found that the only solution is to use the old version CInjectLib64Func code.

// InjectLibrary.c version: 1.0.5 ? date: 2013-10-01
....
const UCHAR CInjectLib64Func[207] =
{ ......
...... };

The other versions of madshi library - for example, 4.2.1, 4.1.3, 3.1.17 - make the same problem.
And the only replace of CInjectLib64Func ( 4.2.1 or 4.1.3 ) makes the problem solved.

We are curious about the difference between CInjectLib64Func codes.

Could we use the old version CInjectLib64Func code ( in InjectLibrary.c ) ?
( I think that it's madshi version is 3.1.6 or other old version . )

Thank you.
madshi
Site Admin
Posts: 10541
Joined: Sun Mar 21, 2004 5:25 pm

Re: Could we use the old version of CInjectLib64Func?

Post by madshi »

Does using the INJECT_ALLOW_THREAD flag help?
Post Reply