MadExcept not working - hints at diagnosis needed

delphi package - automated exception handling

MadExcept not working - hints at diagnosis needed

Postby richp10 » Mon Nov 19, 2018 5:36 pm

At some point Madexcept stopped working and I didn't notice (poor testing..)

Delphi 7 app, MadExcept 4.0.20 - enable madexcept ticked in settings.

I raise a test Egeneric error but the Madexcept dialog does not come up.

I recently updated my memory manager to this - https://github.com/maximmasiutin/FastMM4-AVX - though I have tried disabling it and it makes no difference.

Would you mind giving me some pointers on how to diagnose why it is not working.

In the project.dpr the first few uses are:

FastMM4 in 'Shared\FastMM\FastMM4.pas',
madLinkDisAsm,
madListHardware,
madListProcesses,
madListModules,
madExcept,
FastMM4Messages in 'Shared\FastMM\FastMM4Messages.pas',
FastMove in 'Shared\FastCode\FastMove.pas',
FastCode in 'Shared\FastCode\FastCode.pas',

I have tried disabling all the FAST stuff but it does not help.

R
richp10
 
Posts: 9
Joined: Sun Feb 04, 2018 2:05 pm

Re: MadExcept not working - hints at diagnosis needed

Postby madshi » Mon Nov 19, 2018 5:39 pm

Try with a brand new empty test project first. Does it work there?
madshi
Site Admin
 
Posts: 9880
Joined: Sun Mar 21, 2004 5:25 pm

Re: MadExcept not working - hints at diagnosis needed

Postby richp10 » Mon Nov 19, 2018 8:15 pm

Great suggestion - and the answer is no, it still does not work. Just created a new project, enabled Madexcept and raised exception in the form create.

the DPR uses are I think as expected:

Code: Select all
uses
  madExcept,
  madLinkDisAsm,
  madListHardware,
  madListProcesses,
  madListModules,
  Forms,
  Unit1 in 'Unit1.pas' {Form1};


Exception handled without MadExcept. Weird.
richp10
 
Posts: 9
Joined: Sun Feb 04, 2018 2:05 pm

Re: MadExcept not working - hints at diagnosis needed

Postby madshi » Mon Nov 19, 2018 9:14 pm

Is this a standard madExcept installation? Are all files, all registry keys and all Delphi library settings etc all exactly the same way the madExcept installer made them?

Might make sense to do a cleanup like this:

1) Uninstall madCollection.
2) Search harddisk and registry for mad*.* and delete everything that belongs to madCollection.
3) Start Delphi to make sure madExcept is gone without a trace - and Delphi starts up without any complaints.
4) Reinstall madCollection.

Does everything work after the reinstall?
madshi
Site Admin
 
Posts: 9880
Joined: Sun Mar 21, 2004 5:25 pm

Re: MadExcept not working - hints at diagnosis needed

Postby richp10 » Wed Nov 21, 2018 12:50 pm

Thanks so much - that did the trick. There was indeed more than one copy of the source. Did not appear obvious that this was within the search path but hey it worked!

Thanks again..
richp10
 
Posts: 9
Joined: Sun Feb 04, 2018 2:05 pm

Re: MadExcept not working - hints at diagnosis needed

Postby madshi » Wed Nov 21, 2018 12:56 pm

Glad to hear that!
madshi
Site Admin
 
Posts: 9880
Joined: Sun Mar 21, 2004 5:25 pm


Return to madExcept

Who is online

Users browsing this forum: No registered users and 2 guests

cron