AV when accessing UserSession

delphi package - automated exception handling

AV when accessing UserSession

Postby ZSL » Wed Nov 01, 2017 7:24 am

Intraweb and MAD 4.xx

Code extract below causes an AV when accessing UserSession.

Can anyone please tell me how to access UserSession details with getting an AV

TIA

Code: Select all
{$IFDEF madExcept}

procedure AddCommandLineHeaderInfo(const exceptIntf: IMEException; var handled: boolean);
begin

  exceptIntf.BugReportHeader['Product'] := 'Odyssey';
  exceptIntf.BugReportHeader['Practice Name'] := UserSession.gv_Site.PracticeName;
  exceptIntf.BugReportHeader['User #'] := UserSession.gv_User.UserNumberStr;
  exceptIntf.BugReportHeader['User ID'] := UserSession.gv_User.UserID;
  exceptIntf.BugReportHeader['IP Address'] := UserSession.WebApplication.IP;
end;

initialization

RegisterExceptionHandler(AddCommandLineHeaderInfo, stDontSync);

{$ENDIF}
ZSL
 
Posts: 28
Joined: Thu Mar 31, 2016 11:23 pm

Re: AV when accessing UserSession

Postby madshi » Wed Nov 01, 2017 8:58 am

I'm not really an expert on IntraWeb, I'm not sure why it's crashing. Have you tried asking IntraWeb support about it, seeing that it's their code which crashes? A call to UserSession seems innocent enough. Maybe they don't like multi-threading?
madshi
Site Admin
 
Posts: 9469
Joined: Sun Mar 21, 2004 5:25 pm

Re: AV when accessing UserSession

Postby ZSL » Wed Nov 01, 2017 9:27 pm

Hi,

I am relaying message from Intraweb

Make sure your Madshi version matches the IW version. They "hack" into
IW in a binary way and it breaks from time to time.

We have offered to work with them to put in official hooks for them, but
I've never heard back from them. Maybe its in their spam folder, or
maybe they arent interested. Not sure.

If you have contact with them, please alert them that our offer is still
open so they don't have to hack in in a brittle manner.


https://forums.embarcadero.com/post!reply.jspa?messageID=905505
ZSL
 
Posts: 28
Joined: Thu Mar 31, 2016 11:23 pm

Re: AV when accessing UserSession

Postby ZSL » Thu Nov 02, 2017 7:33 pm

Please let us know if you have seen this post and whether or not you will work with Intrawest.
ZSL
 
Posts: 28
Joined: Thu Mar 31, 2016 11:23 pm

Re: AV when accessing UserSession

Postby madshi » Thu Nov 02, 2017 7:49 pm

I've seen your reply, but I'm currently busy on a project for a high-priority customer. Might get to the IntraWeb problem early next week.

FWIW, I'm somewhat doubtful that the way madExcept hooks into the IW exceptions is at fault for this problem. It's possible, but then why does the crash occur in the moment when accessing "UserSession"?

Can you reproduce this problem with a small test project, ideally one that doesn't require a webserver with ISAPI report or things like that. So IW standalone somehow?
madshi
Site Admin
 
Posts: 9469
Joined: Sun Mar 21, 2004 5:25 pm

Re: AV when accessing UserSession

Postby ZSL » Tue Nov 14, 2017 6:57 pm

Any update on this?

It is crashing when accessing public variable in UserSession. The app continues to operate but FYI the actual AV in the function is not reported
ZSL
 
Posts: 28
Joined: Thu Mar 31, 2016 11:23 pm

Re: AV when accessing UserSession

Postby madshi » Tue Nov 14, 2017 7:03 pm

Can you reproduce this problem with a small test project, ideally one that doesn't require a webserver with ISAPI report or things like that. So IW standalone somehow?
madshi
Site Admin
 
Posts: 9469
Joined: Sun Mar 21, 2004 5:25 pm

Re: AV when accessing UserSession

Postby ZSL » Tue Nov 14, 2017 7:18 pm

I will do this later today.
ZSL
 
Posts: 28
Joined: Thu Mar 31, 2016 11:23 pm

Re: AV when accessing UserSession

Postby ZSL » Wed Nov 15, 2017 7:07 am

Here is a simple example.

iwprj1.7z
(1.98 KiB) Downloaded 8 times
ZSL
 
Posts: 28
Joined: Thu Mar 31, 2016 11:23 pm

Re: AV when accessing UserSession

Postby ZSL » Thu Nov 16, 2017 5:56 pm

Any update on this..

Thanks
ZSL
 
Posts: 28
Joined: Thu Mar 31, 2016 11:23 pm

Re: AV when accessing UserSession

Postby ZSL » Tue Nov 21, 2017 10:54 am

Bump...
ZSL
 
Posts: 28
Joined: Thu Mar 31, 2016 11:23 pm

Re: AV when accessing UserSession

Postby ZSL » Wed Nov 22, 2017 7:12 pm

Is this going to be answered.....
ZSL
 
Posts: 28
Joined: Thu Mar 31, 2016 11:23 pm

Re: AV when accessing UserSession

Postby madshi » Wed Nov 22, 2017 7:33 pm

I'm sorry for the very sluggish response. I try my best to get this issue looked at until the end of the week.
madshi
Site Admin
 
Posts: 9469
Joined: Sun Mar 21, 2004 5:25 pm

Re: AV when accessing UserSession

Postby ZSL » Wed Nov 22, 2017 7:55 pm

Thank you.

It is just that the silence worried me :wink:
ZSL
 
Posts: 28
Joined: Thu Mar 31, 2016 11:23 pm

Re: AV when accessing UserSession

Postby ZSL » Thu Nov 30, 2017 2:20 am

Any update on this, please..
ZSL
 
Posts: 28
Joined: Thu Mar 31, 2016 11:23 pm

Next

Return to madExcept

Who is online

Users browsing this forum: No registered users and 4 guests

cron