using smtp.office365.com for sending bug reports?

delphi package - automated exception handling

using smtp.office365.com for sending bug reports?

Postby Whookie » Wed Oct 18, 2017 1:24 pm

Hi,
we recently switched email services and at the moment I try to get bugreports using smtp.office365.com (port: 587, TLS). As it seems connection is established and there is TLSv1.2 communication with the server (used Wireshark to sniff packages). At some point I see stuff like:
Code: Select all
source        dest.
office.ip     my.ip        TLSv1.2    251    Application Data
my.ip         office.ip    TLSv1.2    129    Application Data
office.ip     my.ip        TLSv1.2    187    Application Data
my.ip         office.ip    TLSv1.2    139    Encryption Alert
my.ip         office.ip    TCP         54   .port. [FIN, ACK]


After that entry there are two TCP FIN-entries closing both TCP connections and I get an error message that sending has failed.

So has anybody a working configuration with these settings?

TIA
Whookie
 
Posts: 7
Joined: Fri May 29, 2015 8:20 am

Re: using smtp.office365.com for sending bug reports?

Postby madshi » Wed Oct 18, 2017 4:23 pm

Using Wireshark is what I'd do myself to debug this, plus maybe set breakpoints in madExcept.pas to figure out at which code location it fails exactly.

I don't have an office365.com email address, so I can't really test it. Could be a bug in madExcept, or maybe Microsoft's TLS implementation (which madExcept is using) might be broken or incomplete. It's hard to say for me.

Maybe you could give debugging a quick try? You can do that by copying madExcept.pas and mad.inc into your project folder. Afterwards you should be able to set breakpoints in madExcept. SMTP mailing is done by calling "TSmtp.Create", then the methods "SendMail" and "Finalize".
madshi
Site Admin
 
Posts: 9431
Joined: Sun Mar 21, 2004 5:25 pm


Return to madExcept

Who is online

Users browsing this forum: No registered users and 2 guests

cron