Binary is not being patched

delphi package - automated exception handling

Binary is not being patched

Postby mafebresv » Thu Sep 28, 2017 2:53 pm

Hello,

I am using madExcept 4.0.17 and when using the madExceptPatch on my development computer it works as expected.

Image
Ignore the message "map file is already appended" as this binary was already patched properly.

Exitcode is 0, so everything is ok:
Image

The problem is that using the same version of madExcept and binary files, madExceptPatch does not work in a different computer:
Image
As you can see, the message "Binary patched" does not appear and the exe is not patched. Exit code is 0 so it seems there was not an error.

I tried already different things to troubleshot it but I can't find the reason. Any ideas?
mafebresv
 
Posts: 2
Joined: Thu Sep 28, 2017 2:40 pm

Re: Binary is not being patched

Postby madshi » Thu Sep 28, 2017 6:04 pm

If Binary patches does not appear, then probably madExceptPatch didn't think it necessary to patch the binary, which probably means that it didn't think the madExcept settings file (*.mes) asked for that. Are you sure that the *.mes file is exactly the same on both PCs?
madshi
Site Admin
 
Posts: 9469
Joined: Sun Mar 21, 2004 5:25 pm

Re: Binary is not being patched

Postby mafebresv » Thu Sep 28, 2017 8:36 pm

Yes, same mes file in both machines.

The strange thing is that if I copy the exe file generated in the second machine to my first machine I get the same issue: No "Binary patched" message so it seems Delphi is generating a different EXE in the second machine that can't be patched by madExceptPatch for some reason. I am using Delphi 2006 Update 2 in both machines.

Attached is madExceptWizard,txt. i have noticed that there are a lot of "not found" messages...
mafebresv
 
Posts: 2
Joined: Thu Sep 28, 2017 2:40 pm

Re: Binary is not being patched

Postby madshi » Thu Sep 28, 2017 8:45 pm

The attachment is missing. Anyway, sounds like on your 2nd machine the madExcept code is not linked into your EXE file. Are you building inside of the IDE, or via command line? Please double check that "madExcept" is in the project's uses clause on the 2nd machine.
madshi
Site Admin
 
Posts: 9469
Joined: Sun Mar 21, 2004 5:25 pm


Return to madExcept

Who is online

Users browsing this forum: No registered users and 5 guests