Page 1 of 1

Errors after installing in BDS2006 on Vista

PostPosted: Wed Feb 14, 2007 8:59 pm
by cmatrix
BDS 2006 (Turbo Delphi)
Vista

I just installed MadCollectionVista. On starting Delphi I get an error for every mad bpl: Can't load package...Access is denied... How do I get rid of these errors?

thanks

PostPosted: Thu Feb 15, 2007 10:56 am
by madshi
Hmmmm... That sounds interesting. Can you please check NTFS security attributes for the madCollection installation folder? Just as a test please add "Everyone". You can remove it later, it's just a test to find out whether that's the problem or not.

PostPosted: Thu Feb 15, 2007 7:30 pm
by cmatrix
Adding "Everyone" to the DeXter folder had no effect.

PostPosted: Fri Feb 16, 2007 11:50 am
by madshi
Are the packages listed in the list of installed packages in the Delphi IDE? If so, are they checked there? If not, could you please try to check "madBasic_.bpl"? What happens then? If you can't check it, could you please try to load it into the editor? Of course you'll get junk into the editor, as it's not a text file. But I just want to find out whether opening and reading the file works.

Thanks!

PostPosted: Fri Feb 16, 2007 12:58 pm
by cmatrix
The packages are listed as installed packages in the Delphi IDE but are not checked. When I try to check "madBasic_.bpl" I get the exact same error as on starting the IDE. When I try to load it into the editor it says "You don't have permission to open this file".

No matter what perms I set on the folders they are not propagating to the files themselves. I have to add the User group to the file permissions of each bpl file. Then they all load.

PostPosted: Fri Feb 16, 2007 1:16 pm
by madshi
That's quite strange. I mean if the madCollection installer was able to CREATE these files, why is Delphi not able to read them? Very strange...

Anyway, can you live with the workaround to give the bpls additional permissions?

Addins permissions to folders only works if you ask Windows to propagate the added permissions to subfolders, I think. But sometimes this whole rights management system can be quite confusing... :confused:

PostPosted: Fri Feb 16, 2007 4:33 pm
by cmatrix
The files would have been created with the Admin account but they need to be given permissions for ordinary users to read them. It's now working for me but as more move to Vista you're probably going to see this problem again.

Now I can load Delphi but when I try to compile an app I get [Pascal Fatal Error]...F1026 File not found: 'C:\Program Files\madCollection\madExcept\DeXter\madExcept.dcu'. The weird thing is I have put 'C:\Program Files\madCollection\madExcept\DeXter' in both the Library path and the Browsing path. Again it is found when you give the dcu file read perms for Users. AFAICS C:\Program Files\ has read perms for User and it is supposed to propagate to all subfolders...Aghhh!

:crazy:

PostPosted: Fri Feb 16, 2007 4:38 pm
by madshi
Ok, thanks, I'll see whether I can solve this problem in one of the next builds. For now I guess you have to manually set the appropriate access rights... :?

PostPosted: Fri Feb 16, 2007 8:13 pm
by cmatrix
Someone from the MS groups thinks the User group should always already have read access to the Program Files group. Is it possible the madCollection installer is overwriting these perms?

PostPosted: Fri Feb 16, 2007 9:35 pm
by madshi
No, madCollection is not changing NTFS rights! Not intentionally, anyway...

Re: Errors after installing in BDS2006 on Vista

PostPosted: Sat Aug 30, 2014 10:31 am
by RobinP
Hi,
FYI - I just got this again when installing on Windows 7 for C++ Builder XE3. It seems the directories all have read access from the "Users" group, but not the actual files. I've solved it in the meantime by installing to "C:\Components", where I have other stuff that has obviously had the same problem. Robin

Re: Errors after installing in BDS2006 on Vista

PostPosted: Tue Sep 02, 2014 9:07 am
by RobinP
Update: installing in C:\Components still didn't fix it, I had to manually change the permissions for the whole directory.

Re: Errors after installing in BDS2006 on Vista

PostPosted: Thu Sep 04, 2014 9:40 am
by madshi
Sounds strange. I've no idea why that happens. The weirdest thing is that it seems to work just fine for 99.9% of all users... :confused:

Re: Errors after installing in BDS2006 on Vista

PostPosted: Fri Sep 12, 2014 9:01 am
by Krystian
I've had similar/same issue on madExcept installation directory few months ago (XE5.2, Win7Pro64 SP1). There was also some issues with Owner of files/directories. IIRC it was after updating madExcept, but I cannot reproduce it now.
I'm not installing it in Program Files, but in C:\DelphiComponents\madCollection

I've ended up with:
- uninstalling madExcept
- removing madCollection directory (as I remember I had to take ownership of directory with "Replace owner on subcontainers and objects")
- clean install od madExcept
- and after that installation there was no changes on directories/files permissions.