Page 1 of 1

No LogFile Created

PostPosted: Fri Jan 19, 2018 2:43 am
by KevinX3
Apologies for the Newbie question.

I have searched the forum and cannot find an answer.

RS XE7 with MadExcept Installed and enabled

I have the path to the logfile set to C:\EMP Logs\BugReport.txt. No matter what, I never get a bug report created. I have tried leaving the absolute path and just putting in BugReport.txt, but no bug report is created in AppData.

Any ideas what I might be doing wrong??

Thanks,
Kevin

Re: No LogFile Created

PostPosted: Fri Jan 19, 2018 9:01 am
by madshi
Do you have "automatically save bug report" enabled in the madExcept settings? Does your EXE have write access to "C:\EMP Logs\BugReport.txt"?

Re: No LogFile Created

PostPosted: Fri Jan 19, 2018 10:32 pm
by KevinX3
Hi,

Do you have "automatically save bug report" enabled in the madExcept settings?

Yes
Image
Does your EXE have write access to "C:\EMP Logs\BugReport.txt"?

Yes, other logfile (from LoggerPro for example) happily write to that folder. I'm sure it's something simple, but I don't know what. I have also tried setting the logfile folder to {App Directory}\Logs (I do that for other logfiles as well), but that also did not work:
Code: Select all
      // LogFile setup
      sLogFolder := IncludeTrailingPathDelimiter(ExtractFilePath(ParamStr(0))) + 'logs';
      if not(DirectoryExists(sLogFolder)) then
        ForceDirectories(sLogFolder);
      sProcessID := inttostr(GetCurrentProcessId);
      sLogFileName := 'MadExcept_DbXConnect_' + FormatDateTime('YYYYMMDD',now) + '_' + sProcessID + '.log';
      MESettings.BugReportFile := sLogFolder + sLogFileName;

Re: No LogFile Created

PostPosted: Fri Jan 19, 2018 11:05 pm
by madshi
Can you reproduce this problem in a simple brand new almost empty test project? If so, can you make that test project available to me?