Page 1 of 1

ANN: madCollection 2.7.11.0 - with XE8 support

PostPosted: Tue Apr 21, 2015 12:06 pm
by madshi
Today I'm releasing madCollection 2.7.11.0:

http://madshi.net/madCollection.exe (installer 2.7.11.0)

madExcept 4.0.12 comes with the following changes:

(1) added support for RAD Studio XE8
(2) added detection for Windows 8.1, Windows 10 etc
(3) a couple of small bug fixes

madCodeHook 3.1.9 comes with the following changes:

(1) fixed: rare injection/hook instability bug
(2) fixed: rare IPC stability bug
(3) memory allocation performance improvement

Re: ANN: madCollection 2.7.11.0 - with XE8 support

PostPosted: Wed Aug 12, 2015 11:37 am
by Flupmans
Not sure (first time- I have to post my question here...
After installing Delphi XE8 (add XE2 before), I installed Madshi
But nothing appears as package in the IDE
So I put the packages manually
But now when I compile, it says unit 'madExcept' not found
Where shall I reference it ?

Re: ANN: madCollection 2.7.11.0 - with XE8 support

PostPosted: Tue Aug 18, 2015 7:11 pm
by madshi
Do you have a madExcept 4 license? madExcept 3 does not support XE8, only madExcept 4 does.

Re: ANN: madCollection 2.7.11.0 - with XE8 support

PostPosted: Tue Sep 22, 2015 12:14 pm
by Flupmans
Sorry for the delay
Yes, it is 4.0.12
Finally I copied the needed files manually in on directory and installed the packages from there

Re: ANN: madCollection 2.7.11.0 - with XE8 support

PostPosted: Tue Sep 22, 2015 2:54 pm
by madshi
Then I don't know why the installer didn't do the job for you. Normally it does. My best guess is that there are some old madExcept files flying around on your PC where they shouldn't be. In order to fix that I'd suggest a full cleanup like this:

1) Uninstall madCollection.
2) Search harddisk and registry for mad*.* and remove everything that belongs to madCollection.
3) Reinstall.

That usually takes care of problems like this.