Search found 48 matches

by nomen
Wed Sep 16, 2015 6:45 am
Forum: madCodeHook
Topic: Microsoft Edge hooking
Replies: 36
Views: 28459

Re: Microsoft Edge hooking

Forgive me but I have not had time to do more tests, I'm very busy these days.
I'll try next week.
by nomen
Thu Sep 03, 2015 8:51 pm
Forum: madCodeHook
Topic: Microsoft Edge hooking
Replies: 36
Views: 28459

Re: Microsoft Edge hooking

Ok, I see: the problem is in my code or in project setting.
As Madshi says I will start with PrintMonitor and put my code step by step.
Thank you very much for your help!

I will tell you.
by nomen
Wed Sep 02, 2015 4:44 pm
Forum: madCodeHook
Topic: Microsoft Edge hooking
Replies: 36
Views: 28459

Re: Microsoft Edge hooking

Thank you Madshi!!
I wll try it.
by nomen
Wed Sep 02, 2015 4:09 pm
Forum: madCodeHook
Topic: Microsoft Edge hooking
Replies: 36
Views: 28459

Re: Microsoft Edge hooking

Nothing works! :cry: I do check your PrintMonitor settings and it is the same I have. The only difference is Base Address and I do change to 0x57800000 as your program (I think this should not affect but I do change it). I do check the DLL code and is the same ( I do not use CollectHooks but this is...
by nomen
Mon Aug 31, 2015 12:08 pm
Forum: madCodeHook
Topic: Microsoft Edge hooking
Replies: 36
Views: 28459

Re: Microsoft Edge hooking

Hi all: I downloaded PrintMonitor and give read/execute access to ALL_APPLICATION_PACKAGES to the hook dlls. Test the app with Internet Explorer and I can see the hooks. Works correctly. Then I test the app with Edge and there are not hooks. But there is a curious thing because I can check with Proc...
by nomen
Mon Aug 31, 2015 10:08 am
Forum: madCodeHook
Topic: Microsoft Edge hooking
Replies: 36
Views: 28459

Re: Microsoft Edge hooking

Thank you Madshi.
I will check it at home!
by nomen
Mon Aug 31, 2015 9:36 am
Forum: madCodeHook
Topic: Microsoft Edge hooking
Replies: 36
Views: 28459

Re: Microsoft Edge hooking

I checked with ProcessExplorer my DLL is NOT loaded in Edge. I have fount this article http://blog.nektra.com/main/2013/02/25/injecting-a-dll-in-modernui-metro-app-win8. It seems interesting but I have not read it in depth. Now I 'm at work , I'll look in the afternoon. By the way , if anyone has an...
by nomen
Mon Aug 31, 2015 8:33 am
Forum: madCodeHook
Topic: Microsoft Edge hooking
Replies: 36
Views: 28459

Re: Microsoft Edge hooking

There has been no luck :sorry: As you can see in the attachment ALL APPLICATION PACKAGES (TODOS LOS PAQUETES DE APLICACIONES in spanish) group is added to its file permissions. It has read and execution permissions. Is this enough? The DLL has not manifest. In the previous version it has an empty ma...
by nomen
Sat Aug 29, 2015 9:45 pm
Forum: madCodeHook
Topic: Microsoft Edge hooking
Replies: 36
Views: 28459

Re: Microsoft Edge hooking

Thank you very much Iconic!
I will work on this direction and I'll tell you!
by nomen
Sat Aug 29, 2015 6:55 pm
Forum: madCodeHook
Topic: Windows 10 support
Replies: 49
Views: 77582

Re: Windows 10 support

OK, no problem!
Your work is great!
by nomen
Sat Aug 29, 2015 6:48 pm
Forum: madCodeHook
Topic: Windows 10 support
Replies: 49
Views: 77582

Re: Windows 10 support

Hi Madshi:

Did you finally renew the certificate?
You will create a new version of MadCodeHook you when I get ?

Thanks!
by nomen
Sat Aug 29, 2015 6:27 pm
Forum: madCodeHook
Topic: Microsoft Edge hooking
Replies: 36
Views: 28459

Re: Microsoft Edge hooking

I hope it!
I´m trying to doiscover with API Monitor but Windows 10 is not supported and does not help me. :sorry:
by nomen
Sat Aug 29, 2015 5:36 pm
Forum: madCodeHook
Topic: Microsoft Edge hooking
Replies: 36
Views: 28459

Microsoft Edge hooking

Hi all: I am hooking the next dll functions: HookAPI("WSOCK32.DLL", "send", sendCallback, (PVOID*) &sendNext); HookAPI("WSOCK32.DLL", "sendto", sendtoCallback, (PVOID*) &sendtoNext); HookAPI("WS2_32.DLL", "WSASend", WSASendCallback,...
by nomen
Thu Jul 30, 2015 10:46 pm
Forum: madCodeHook
Topic: Windows 10 support
Replies: 49
Views: 77582

Re: Windows 10 support

Hi Madshi: I do not know what has happened: I have made a fresh installation of my application on a clean image of Windows 10 and no longer occurs SYSTEM_SERVICE_EXCEPTION error. I restart it about 10 times and no problem. I saw that the date on which the VMware was created was 2014/10/27. Maybe it ...
by nomen
Wed Jul 29, 2015 10:22 am
Forum: madCodeHook
Topic: Windows 10 support
Replies: 49
Views: 77582

Re: Windows 10 support

Hi Madshi: No, I´m not sure this is caused by madCodeHook. I don´t know how can I know te causes of the error. Do you know where is saved the error info? Yes, in my case, the reboot is with the injection still active. I will make the test uninjecting before the reboot. Maybe I will try it tomorrow, ...